Weird wrong number of arguments error

Note to (self|google): when you encounter this error again:

wrong number of arguments (1 for 0)

And the framework trace doesn't give any clue on where this happens, look for reserved words as controller method names. I had a 'send' action in my controller, and renaming it to send_feedback fixed it for me.

I'm not sure which other words are forbidden for controller names, but you can check this page on the Rails wiki if you're not sure about one: http://wiki.rubyonrails.org/rails/pages/ReservedWords

In a reading mood?

Have something to add?



  • (required, but not displayed)

  • (optional)

About this article

You’re reading an entry titled “Weird wrong number of arguments error”. Written

undefined tag `time_ago_in_words'
ago (21/05/2009) — and archived under rails, troubleshooting. So far, 0 people (dis)agreed with me, what do you think?

What the fuzz is all about

  1. 2 pages are tagged with WYM
  2. 1 page is tagged with absolute-urls
  3. 1 page is tagged with arrrrcamp
  4. 2 pages are tagged with documentation
  5. 2 pages are tagged with editor
  6. 2 pages are tagged with extension
  7. 2 pages are tagged with extensions
  8. 1 page is tagged with minitorial
  9. 1 page is tagged with navigation
  10. 10 pages are tagged with radiant
  11. 4 pages are tagged with rails
  12. 2 pages are tagged with ruby
  13. 2 pages are tagged with shell
  14. 1 page is tagged with sifr
  15. 2 pages are tagged with troubleshooting

Github activity

More places where you can find me

Back to top